Git push: Everything up-to-date, but it's not uploaded to the remote repository

Hey,
I successfully pushed a new branch to my project doing
git status
git add -A (should add all changed files)
git commit -m „Changes“
git push
It worked fine.

Now I changed some files locally and want to push the changes, so simply update the branch.

When I add -A, commit -m “blabla”, and then push, I get: Everything up-to-date. But the remote repository is not updated.
I know there are several similar questions, but none of the answers worked here.

git status
Your branch is up to date with ‘origin/branchname’.
nothing to commit, working tree clean

git remote -v
origin https://gitlab.com/bla/bla.git (fetch)
origin https://gitlab.com/bla/bla.git (push)

git checkout
Your branch is up to date with ‘origin/branchname’.

.git/config seems to be alright.

git push origin branchname didn’t work.
git push --force didn’t work.
git push origin HEAD:branchname didn’t work.

I would really appreciate your help here, I’m trying it already for hours and all I want is to simply update the remote branch… Can’t be that hard. Thank you so much.