GIT Versions supprted by GITLAB 8.7.5-ee?

Hi,

I wanted to know, what are all the GIT versions supported by GITLAB (or) till which version of GIT is supported by GITLAB 8.7.5-ee?

To elaborate:
I have GITLAB server with version 8.7.5-ee.
I wanted to know whether my GITLAB supports GIT Version 1.5?
In the way, I wnated to know what are all versions supported and unsupported by GITLAB?

Does this information already exists? If so could you please provide some links?

Thanks and Regards,
Vijay Reddy.

Hi

This is a just a clue.

Please run the below command.
sudo gitlab-rake gitlab:check SANITIZE=true --trace

This is a rake command which checks the health of the system , in one of the checks it checks the minimum git version required for that version.

In the above pic i have 8.8.0 CE installed, rake commands checks if the git version is > 2.7.3
I hope this helps.

Hi,

GITLAB supports all the older version of GIT.
A small reference that can support:
https://git-scm.com/book/en/v2/Getting-Started-Installing-Git (Please look at the note).

I have tested the same and it worked fine. I used git 1.7.1 and tried all the general actions and everything seems to be fine for me.

Thanks and Regards,
VijayReddy.

Hi

There is a small ceveat in case of source method installations. Please read this note

Hi Ershad,

Thank you very much for the valuable information.

The post was more taking about the server version of GIT. I was more talking in the perspective of client version of GITbut not the server version of GITLAB. Currently our GITLAB server version is more than the version as suggested in the post given by you.

Please do correct if I’m missing something.

Thanks and Regards,
Vijay Reddy.

Hi

No where in the post the word client was mentioned so I took it as gitlab server version, that was the misunderstanding.