Gitlab 7.7.2 ldap gives Ldapmain "invalid credentialls"

gitlab_rails['ldap_enabled'] = true

gitlab_rails['ldap_servers'] = YAML.load

main: # 'main' is the GitLab 'provider ID' of this LDAP server label: 'LDAP'

 host: 'ServerLdap'

 port: 389
 uid: 'sAMAccountName'
 method: 'plain' # "tls" or "ssl" or "plain"
 bind_dn: 'uid=***,ou=JeniePortal,ou=applications,***'

 password: 'passw@rd'
 active_directory: false
 allow_username_or_email_login: false
 base: '0=sample'
 user_filter: ''

gitlab 7.7.2 ldap gives Ldapmain “invalid credentialls” . itried the binding userid password still same error . i tested user id and password against different system credentialls how to troubleshoot the issue

Is this Issue resolved? I do have the same issue and I do not think its because of Whitespace issue.

Please direct me to where I can find the solution…


Are you using an AD 2003 by any chance?

And can you post the relevant parts of the log?

I get the same error. its openDS on centos 6.4 . are we getting any fix for this? Thx.

We need some more informations for that.

  • Gitlab version
  • Ldap Version + name (openldap/ad?)
  • relevant error message from the log.


I get the same error too. I’m using GitLab 7.7.2
We are using AD for our LDAP.
I get the following message on the browser when trying to connect:
Could not authorize you from Ldapmain because "Invalid credentials"
See screenshot…

Does anyone know why we are getting this message? I don’t know where the log files are to see these ldap errors.

please try 7.8 it fixed the issue .

Hi Mod , Please remove the Reply of 7/9 , Many Thanks