Gitlab api version

Hi all,

Could you please tell me how can i update the api version v3 to v4?
… Bad response code: 410 Request url: /api/v3/projects/starred?archived=false&page=1&per_page=100 Data map[error:API V3 is no longer supported. Use API V4 instead.][Macaron] Completed /api/boards/starred 401 Unauthorized in 33.245717ms …

kanban portal stopped after updating gitlab. please suggest

They have actually made documentation about this:

https://docs.gitlab.com/ee/api/v3_to_v4.html

Yes, I have looked in to it. but there is no method of changing the apis version? kanban doesnot work with api version 3.

As that page says:
API v3 was removed in GitLab 11.0
and you naturally can’t change to something that is removed.