GitLab CI for GitHub fails to configure webhook

Tried adding another external GitHub repository like I normally do (currently have added about 16 other repositories this way) but today I was prompted to provide a GitHub Personal Access Token. I’ve never been prompted for this before but after a bit of googling figured it may be due to this

Has something recently changed on with regards to using OAuth/Personal Access Tokens for this?

After reading the above article I created a GitHub Personal Access Token following this guide at which point the repository successfully synced and was available in GitLab as expected. After making some changes to the repository I noticed GitLab CI wasn’t detecting the changes and firing the pipeline so I went to check the webhook on GitHub and noticed it was missing.

The documentation suggests one should be setup automatically but this doesn’t appear to be the case.

I’ve solved the GitHub webhook creation issue (requires ‘Admin’ permission on repository).

I’d still quite like to know if the reason why I’m being prompted to provide a GitHub Personal Access Token is related to the issue I listed above.