Gitlab.com hanging up on Push


#1

Hello,

I’m attempting to push my commits to the remote repository on gitlab.com, but the connection keeps getting reset / the remote is hanging up. Here is what my remote origin looks like-- https://i.imgur.com/rvKe9Ko.png

Here is what the error looks like-- https://i.imgur.com/N3sgNaO.png

I have pushed successfully to the remote repository many times before, and I don’t believe any git configuration has changed client-side. Gitlab.com’s status pages don’t indicate any service issues either. Does anyone have any suggestions / thoughts?

Thank you!


#2

I’m not a Windows user, so I’m not sure it will apply. On Linux I’d run this command to see more verbose output for the ssh connection:

GIT_SSH_COMMAND="ssh -v" git push origin master

Does pulling or cloning a new repo give you the same error?

Also a tip for future posts: rather than linking to images, I’d suggest pasting the terminal output as text in the forum post. It’s not only easier for people to read your post, but also makes the post searchable. In general, the less effort required by others to understand your issue, the more chances to get help.


#3

There appears to be no additional output coming from the SSH, as seen below–

ayarger@DESKTOP-U845RB7 MINGW64 ~/Documents/dev/unity/DuoFuego (master)
$ GIT_SSH_COMMAND="ssh -v"

ayarger@DESKTOP-U845RB7 MINGW64 ~/Documents/dev/unity/DuoFuego (master)
$ echo $GIT_SSH_COMMAND
ssh -v

ayarger@DESKTOP-U845RB7 MINGW64 ~/Documents/dev/unity/DuoFuego (master)
$ git push origin master
Counting objects: 1051, done.
Delta compression using up to 8 threads.
Compressing objects: 100% (1046/1046), done.
Connection reset by 35.231.145.151 port 22
fatal: The remote end hung up unexpectedly
fatal: sha1 file '<stdout>' write error: Broken pipe
fatal: The remote end hung up unexpectedly

ayarger@DESKTOP-U845RB7 MINGW64 ~/Documents/dev/unity/DuoFuego (master)
$

I believe the contents being pushed are somewhat large, but I have tried increasing the post buffer to no avail. I have also managed to successfully push all of this repository’s subrepos, but not this one. I’ve read it could be a permissions issue on the remote server, but I don’t have access to it. Any ideas?

Thank you!

(I’m very hesitant to clone and manually migrate changes to the new copy of the repo, since this will not apply any of the deletions I’ve made. Will do as a last resort, but I’d like to know the cause of this issue if possible).


#4

Ah! I’ve gotten around the problem by using https to push, rather than ssh. This feels like it may be a bug with how gitlab.com handles ssh for large pushes.


#5

And now the issue seems to be fixed (no changes on my end).