MR Approvers list different for different users

We are a Bronze tier customer, experiencing a very strange issue. Two users with “Owner” privileges to all the relevant groups and the project in question see different “Approvers” listed in the “Merge request approvals” section of the project’s settings. There are three groups that should be added: “developers”, “devops”, and another we’ll call “consultants” here. All three groups are listed as “Maintainer” members of the project. However the “consultants” group cannot currently actually approve MRs. In trouble-shooting that, which we have not solved, we discovered that different GitLab users with access to change those lists (one is me) see different groups in the “Approvers” list. See the following screenshots:

Note this list has “developers” and “devops”.

Note this list has “developers” and the black-barred one which is the “consultants” group. (Blacked out as it has a company name.)

Things we have tried:

  1. Changing to a different browser in case it was a caching issue. Same thing.
  2. Removing all members and approvers from the project and re-adding them. Same thing. Of note, this remains true even if the person who cannot see the group in the “Approvers” list is the one who adds the group to the list. The group will (re)appear in the other person’s list, but will immediately disappear for the one who added it.