Gitlab Container Registry has no route to host

Hi guys!

I have just ran into an issue where I tried updating my Gitlab postgres version from 9.3 to 9.6. I failed the update last night and reverted my database back to 9.3. In the process of doing that, it seems that my Gitlab Container Registry is down.

It is part of the GitLab Omnibus package CentOS 6.6, so I don’t know how to resolve it… I cannot docker pull any images from anywhere.

I have tried doing a sudo gitlab-ctl restart registry to no avail. The only item that was added to my /etc/gitlab/gitlab.rb was this line: registry_external_url ''

If anyone can provide some help, that will be great.

2017/04/21 12:02:13 [error] 16787#0: *36176 connect() failed (111: Connection refused) while connecting to upstream, client:, server:, request: "GET / HTTP/1.1", upstream: "http://[::1]:5000/", host: ""```


When I stopped my GitLab instance to revert by database update back to 9.3, somehow my firewall rule for my Registry port was removed (4567). Since I was on CentOS, I had to do a sudo lokkit -p 4567:tcp to allow the port again and I could reach my registry again