Gitlab-ctl reconfigure taking forever to complete

I’m following this tutorial to set up gitlab ce in centos 7. And the above mentioned command is taking forever to execute. It has already been 5+ minutes.

According to one of the last forum posts, I tried this command, but even that didn’t work.

systemctl restart gitlab-runsvdir.service

CentOS 7 is old, you should really be using EL8 or EL9 based distributions now.

Also, what is the VPS requirements of your machine? How many CPU did you allocate? How much RAM? How much disk?

A minimal install of Gitlab requires 4cpu, 8GB ram. So if you are lower than this, then you do not meet the hardware requirements and this is why it will be slow.

Better is to follow official Gitlab docs: Download and install GitLab | GitLab

How long does this command take to complete?

Difficult to tell when you didn’t reply to my questions about trying to find out what CPU/RAM you allocated to the VPS.

Restarting should be pretty quick, which makes me think you didn’t create a machine with enough CPU/RAM/disk to work properly.

You fail to say which “above mentioned command” you used from the linked URL, so again, without knowing the command, we cannot tell you how much time to expect.

Provide more details if you want better help and assistance.

Increasing CPU and RAM solved the issue. The command takes around 5 minute to complete.

1 Like