GitLab Docker upgrade from 15.10.0-ce.0 to 15.11.0-ce.0 stuck in Deploy in progress

Hi! I just upgraded GitLab Docker from 15.10.0-ce.0 to 15.11.0-ce.0 but after several minutes, the instance was stuck on Deploy in progress message.

I ran gitlab-ctl deploy-page down and the instance started to work again.

How can I be certain that the upgrade was ok and finished all tasks? Because I know that I can login again into my GitLab instance, but I don’t know if there’s still something not upgraded/migrated.


Usually in the admin page on the instance overview dashboard it should show you what version is running. This would confirm if the upgrade has worked. Also under Admin → Monitoring → Background Migrations you can see if these are running. Although they will also disappear when finished but there is a Failed section to show which ones didn’t work if that occurs.

1 Like

Thanks! @iwalker the version number running in Docker was ok, I always check for that, and it seems that the migrations where fine

1 Like