GITLAB integration with Active Directory

Hello,
I did my first installation of Gitlab (12.10.3)
I need to integrate it with an Active Directory (windows server 2012 r2).

I made the following configuration:

but it’s not working. What would I have done wrong?
note: Windows Server has the windows firewall disabled.

On our server, we set bind_dn: in the format admin-gitlab@example.co.uk. Do you get any errors in any of the logs that could help out.

Hello. I managed to solve this first part.
integration worked.

my question now is … can I configure more than 1 base?

Say I have users in 2 OU’s.
TEST-GITLAB (already configured)
and TEST-GITLAB2 …
how do I set up 2 user bases?

We don’t specify an OU. We just use DC=example,DC=co,DC=uk as that will then allow any domain users access to our server with out limiting to an OU.

@veltusti will you please help to solve my issue .

I am also facing issue and unable to connect with AD server, when i run
" gitlab-rake gitlab:ldap:check"
and output is : Checking LDAP …

LDAP: … Server: ldapmain
LDAP authentication… Failed. Check bind_dn and password configuration values
LDAP users with access to your GitLab server (only showing the first 100 results)

Checking LDAP … Finished

used ldapsearch to verify bind-dn and password and it worked but with gitlab it is not