Gitlab Kubernetes cluster integration: DNS Problem with helm/tiller pod

Hi there
I am going to integrate an existing kubernetes cluster into gitlab. After having solved the nasty formatting problems with the token, helm/tiller installed but from then onwards it is not possible to install any further services/pods like gitlab-runner, knative etc.
Reason is the default dns config of the alpine image helm/tiller relies on which sets in /etc/resolv.conf the options ndots to 5. My resolv.conf in the tiller-deploy pod look like

search gitlab-managed-apps.svc.cluster.local svc.cluster.local cluster.local spenstack.local (…)
options ndots:5

As tiller-deploy allows to open a shell only with user nobody there is no possibility to set the dots option to 1 to allow dns resolution with the standard dns server. I tried also to modify the spec file manually with
kubectl -n gitlab-managed-apps edit deployment/tiller-deploy

and then add corrected DNS params

resources: {}
terminationMessagePath: /dev/termination-log
terminationMessagePolicy: File
- mountPath: /etc/certs
name: tiller-certs
readOnly: true
dnsPolicy: ClusterFirst
- options:
- name: ndots
- value: “1”
restartPolicy: Always
schedulerName: default-scheduler
securityContext: {}
serviceAccount: tiller
serviceAccountName: tiller
terminationGracePeriodSeconds: 30
- name: tiller-certs
defaultMode: 420

But I cannot save the modification afterwards and the spec is left unchanged.
How can I get this ndots parameter changed in /etc/resolv.conf?
Looking forward to your advice

Br br

Have you managed to solve the problem?