GitLab Login Issue Community Edition

Hi Guys,

I am trying to install GitLab for personal use and facing an issue while accessing it.

Below are the details which I did so far

  1. Installed gitlab CE on local ubuntu
  2. Have created an one Azure VM and assigned DNS name to it
    so that I can use this DNS in external_url of
    /etc/gitlab/gitlab.rb (on local ubuntu)
  3. Below is the final output when I run gitlab-ctl reconfigure

Deprecations:

  • omnibus_gitconfig has been deprecated since 16.10 and will be removed in 17.0. omnibus_gitconfig will be removed in GitLab 17.0. For details and migration instructions, please see: GitLab 16 changes | GitLab

when I try hitting the URL in the chrome, getting the below issue

This site can’t be reached

XXXXX-XX.XXXXX.XXXX.azure.com refused to connect.

Can someone help me with this issue?

If Azure works like AWS, you normally need to create ingress rules to allow external traffic get to your instance. Have you checked/verified to ensure that port 80/443 are allowed on your Azure ingress rules?

Also check that your instance doesn’t have a firewall running on it like iptables/nftables/firewalld etc since maybe it’s blocked there as well.

The message you posted shows that it cannot be reached which it means it never got to the Azure instance. So it can only really be the ingress or firewall rules blocking the traffic.

Thanks for the reply.
Yes, I have already allowed traffic for the port 80/443 in Azure VM, also enable ufw in the ubuntu server as well.
But still I am not able to access the URL.