Gitlab new Installation

I’m fairly new to Gitlab and need to upgrade our instance , I have a new server DR and followed the this link for the install - Download and install GitLab | GitLab
Every step worked fine until I got to this step - Add the GitLab package repository and install the packages

Was getting issues trying to get to the site so as plan B I decided to get the Gitlab ce image from a different server via nexus and pull it onto my DR server and that worked. I managed to start the container and Gitlab via this command

Sudo podman run --detach
–hostname my hostaname
–publish 443:443 --publish 80:80 --publish 22:22
–name gitlab_ce
–restart always
–volume $GITLAB_HOME/config:/srv/gitlab
–volume $GITLAB_HOME/logs:/srv/log/gitlab
–volume $GITLAB_HOME/data:/srv/gitlab/data
–env GITLAB_CONFIG=“external_url ‘’;”

I’m able to start Gitlab via Browser BUT I cannot get LDAP working this way…
We are using Podman instead of Docker just as a note.

I have tried to add the Gitlab.rb with the LDAP configurations but it does not seem to work or read that file.

Is there a way to add LDAP and Other features using this way of installing Gitlab ?

Hi @Chiefshole
using the official docker install guide you can see how to pass GitLab configuration to container here.

Hi @balonik , Thank you very much for pointing me to the right direction. My issues was that I had the .rb file outside the container. Once I made changes using -
sudo docker exec -it gitlab editor /etc/gitlab/gitlab.rb , I was able to start configure LDAP and other configs…
Thanks again