Gitlab-rake gives a git disk access denied error

sudo gitlab-rake gitlab:list_repos

rake aborted!
Gitlab::GitalyClient::StorageSettings::DirectPathAccessError: git disk access denied

I am hopeful someone might be able to guide me as to what might not have access and how to check this, maybe to correct it. Might be a chmod is needed somewhere or adding a user to a group? But maybe it is something inside of a ruby config file? Is there a logfile which might have more details?

Just recently updated to 13.9.3, not sure if this was working before or not. Looking to push to 13.10.0 soon.

thank you

1 Like

I have the same issue when I run

wget -O /tmp/fix-legacy-hashed-storage-migration.rb https://gitlab.com/snippets/2039252/raw
gitlab-rails runner /tmp/fix-legacy-hashed-storage-migration.rb

I can’t migrate 12 project and I clear all my secrets, I am stuck, could this be related. @floutenvy did you solved it?

I have not solved the issue.

Also wonder if error output would help confirm if it is a similar issue or related one.