Gitlab -repocheck.log | Project failed last repository check.| Omnibus

Hi Team ,we received project failed last repository check and when we check repocheck.log we see below message for our projects ,Any help Please.
Could not fsck repository: error: Could not read 0b7ea4ff3efeb4745f2d3b0818de2ad6b24e17ba
failed to parse commit 0b7ea4ff3efeb4745f2d3b0818de2ad6b24e17ba from object database for commit-graph
error: Could not read 10c863f176aa5ca6671f302812a5700bd979717f
failed to parse commit 10c863f176aa5ca6671f302812a5700bd979717f from object database for commit-graph
error: Could not read 118385c2d2e3c5b868505376b665f03abd7eff2c

Describe your question in as much detail as possible:

  • What are you seeing, and how does it differ from what you expect to see?
  • Consider including screenshots, error messages, and/or other helpful visuals
  • What version are you on (Hint: /help) ? and are you using self-managed or
  • What troubleshooting steps have you already taken? Can you link to any docs or other resources so we know where you have been?

Thanks for taking the time to be thorough in your request, it really helps! :blush:

Maintenance commands like these in this post should help:

I have used these in similar situations.


Hi Thanks for the commands , it did followed same and ran the fsck cmd which gave me “failed to parse commit fff5078c3091ba9dce524ae767b04fcf52f21bb3 from object database for commit-graph
Verifying commits in commit graph:” so then i ran gc command followed by fsck , now i dont see any error message
but in gitlab portal when i https://—gitlabURL—/admin/projects?last_repository_check_failed=1 still i see same project .

That’s most likely because the repository check has to run so that it then no longer shows in the failed list. This is scheduled and doesn’t happen immediately so you can wait until it runs later. Or I believe you can manually run it though if I remember right. I think it’s in Settings → General → Advanced → Run Housekeeping on the project that has this issue.

Many Thanks @iwalker i resolved the error on 1 project by doing gc and then manually triggered repo check and the reported project has came green , but for 3 other project i have different error not the same error , here the error is after executing cmd fsck “dangling commit a33e1872ffc8111b7ee1242e298b7253ee54acd8
dangling commit ad43ab050f462aa9aab151d61024b9124224dd78”