Gitlab restore to a new server

Hi!

I need help on restoring our gitlab-8.9.6 (installed via source) repos and data to new server.
Gitlab services won’t start anymore (sidekiq and workhorse are not starting and updating log files).
We can’t find any helpful logs at all… I want to know if there’s a way to restore our data and repos to a new server by getting it from a file or from db or anywhere…

Any help is so much appreciated.

Thank you

  • MD

Why such an old version?

Remember that you can only restore a backup to the exact same version it was made on, so if you need to restore a backup made on 8.9.6, you need to install a new server with 8.9.6.

If you don’t have a backup, you’re in a bad position. I didn’t take over administration of our GitLab installation until we were on 10., so things might have been different (but I suppose it wasn’t much easier) on 8.9.6. Data is spread in multiple places, the most important are probably:

  • repositories in /var/opt/gitlab/gitlab-data/repositories (That’s the path used for omnibus installations, for source installations I believe it’s different, but I don’t remember, neither what it is or where to find it)
  • GitLab internal data in a database (on 8 mysql was supported in addition to PostgreSQL, that is the only supported option today)

but there’s also:

  • artifacts
  • other build data
  • pages
  • LFS data (if enabled)
  • uploaded stuff

I would guess the route of least trouble is to try to get you GitLab running again, and then upgrade it, and implement a good backup strategy.

What did you do when GitLab stopped working?

Thanks @grove for your response.

Why such an old version?

  • I really don’t have an excuse for this…

We really did not do any config change… except on enabling the runner (CI/CD tool)… That’s the time issues started to came up.

We’re still trying to get the Gitlab running again… Just need to prepare the new environment.

Thanks for your input. Will give you all feedback as soon as we’re done with it.

Best regards.