Gitlab runner output stops and job gets stuck

I’m running Gitlab CE in a docker container using the official gitlab docker image. I now run the latest version (13.5.1). I run it on Docker 19 on Ubuntu 20.04. I always have a lot of issues with upgrading the container to the latest image. I always run into permission issues with the database.yml file. And with the upgrade today to 13.5.1 I got issues with Gitaly toml file. But I managed to work around this.

The reason for upgrading was that the runner-output from a pipeline gets stuck after a couple of lines in the job log output. I’m using a runner on Ubuntu 20.04 which is configured to use docker. I use runner version 13.5.0 (amd64), from a DEB package.

The runner is connected and able to pick-up jobs, although this was a more fluent in previous runners and gitlab versions. I see the container getting started and also in the job-logging interface the output is streaming.

After a couple of seconds, there is no more output. But if I run:

docker logs --tail 100 --follow [container runner name]

I see the container running correctly and a lot of output is produced. After a while, the job gets stuck according to gitlab. I do not know where to search or look. It has worked quite well the last couple of months, but since the upgrade to 13.4.x it started to happen. I’m happy to post more logs and try things, let me know what you guys need!

Also, I installed a runner service on my workstation (Windows 10) using docker. The same thing occurs. Also using the latest version (13.5.0).