Gitlab-runner package for Debian 11

When trying to install the gitlab-runner on a Debian 11 system I realised that there is no package for this system available.

When can such a package be expected.

I was testing Gitlab recently on Debian 11, but I just edited the file under /etc/apt/sources.list.d/ and changed bullseye to buster to temporarily use the Debian 10 package.

I would expect Gitlab to be more problematic than just a runner, so it should work fine for you this way at least until Gitlab release an official package.

Your best bet, would be to open an issue here: Issues · GitLab.org / GitLab · GitLab or search first to make sure that no-one has already opened an issue for Gitlab Runners for Bullseye to be created.

I’m also waiting for Gitlab-CE to be released on Debian 11, so I can upgrade my system and move away from Debian 10, but will just have to wait patiently until that time comes.

1 Like