Gitlab ssh issue with git user (Connection closed)

Hi All,

I have installed GitLab Enterprise Edition 9.5.2-ee 65f8414 in Rhel 6.9 and have the setup Up & running now. I have logged in with my user id and added my public ssh key as well.

But now when i try to clone the repo it fails with connection closed error and i tried validating with below command it still fails.

#ssh -T
Connection closed by x.x.x.x

Looking at /var/log/secure I found below lines in my logs ,
sshd[28446]: pam_access(sshd:account): access denied for user git' from
sshd[28446]: pam_winbind(sshd:account): valid_user: wbcGetpwnam gave WBC_ERR_DOMAIN_NOT_FOUND
sshd[28447]: fatal: Access denied for user git by PAM account configuration

I tried adding git user which is local user in “/etc/security/access.conf" and seems i can able to clone now.

Now my question is I assume we dont need ssh access for git user in gitlab server but here from logs its expecting git user exception in access.conf.
Can somone help with this issue and let me know what kind of ssh setting required for git user.