Gitlab Worker Shared Cache 403 Error

Gitlab Runner version: Version 16.4.0
Gitlab Version: 15.11.11-ee

Hello this is my first post here so I hope I’m not doing anything wrong, if I am please let me know and I’ll correct it,
I’ve been having issues with Gitlab Workers using my s3 cache and I’m not sure it’s an issue / where the issue lies anymore.
I’m not using s3 Cache from Amazon but I tried S3 compatible storage from MinIO and Vultr.
Every time I try to use either solution, I get the following error:
.cache/: found 100 matching artifact files and directories
Uploading to
FATAL: received: 403 Forbidden
Failed to create cache
My Gitlab Worker configuration looks like this:

  name = "WinServ02"
  url = ""
  id = 5
  token = "REDACTED"
  token_obtained_at = 2023-05-03T12:12:40Z
  token_expires_at = 0001-01-01T00:00:00Z
  executor = "docker-windows"
  clone_url = ""
  shell = "powershell"
  disable_cache = false
    Type = "s3"
    Shared = true
    Path = "cache"
    ServerAddress = ""
     AccessKey = "REDACTED"
    SecretKey = "REDACTED"
    BucketName = "gitlab"
    BucketLocation = "germany-east0"
    Insecure = false
    tls_verify = false
    image = "python:3.10-windowsservercore-ltsc2022"
    privileged = false
    disable_entrypoint_overwrite = false
    oom_kill_disable = false
    shm_size = 0

CI Script:

  image: python:3.9-windowsservercore-ltsc2022
    - winserv02


  - Set-ExecutionPolicy Bypass -Scope Process -Force; [System.Net.ServicePointManager]::SecurityProtocol = [System.Net.ServicePointManager]::SecurityProtocol -bor 3072; iex ((New-Object System.Net.WebClient).DownloadString(''))
  - $env:Path += ';C:\ProgramData\Chocolatey'
  - choco config set --name="'cacheLocation'" --value="${CI_PROJECT_DIR}/.cache/choco-cache/"
  - python -m pip install --upgrade pip

    key:  "$CI_COMMIT_REF_SLUG"
      - Analysis-00.toc
      - dist/
      - build/build_for_pipeline/
      - .cache/
    policy: pull
  - test

Create Things to cache:
  stage: test
  extends: .dependencies_cache
    policy: pull-push

    - pip3 install -q pandas
    - choco install vcredist2013

Access Policy for S3 Key:

 "Version": "2012-10-17",
 "Statement": [
   "Effect": "Allow",
   "Action": [
   "Effect": "Allow",
   "Action": [
   "Sid": "AllAccess",
   "Effect": "Allow",
   "Action": [
   "Resource": [

I already tried these solutions, none of which seemed to have solved the issue:

I really hope ya’ll can help me I’m really stuck on this one, it seems like it should work but it doesn’t. I feel like I’m missing something obvious here?