Helm chart 4.6.3 -> 4.7.0 -- too many redirects

The problem

I’m trying to upgrade my GitLab Helm chart from 4.6.3 to 4.7.0. The upgrade works but not really. I keep getting “too many redirects” whenever I go to my GitLab URL now.

The errors I’m seeing are, whenever I go to my GitLab URL, I get a “too many redirects” error. Opening up the Network tools, I see a bunch of 308 statuses along with the hostname of my GitLab instance.

I have an idea as to what’s causing this. In the Helm chart changelog, it mentions that the NGINX version upgraded from v0.20.0 to v0.41.2.

For GitLab’s SSL, I’m not providing my own certs–I’m proxying via CloudFlare (so it’s a cert provided by CloudFlare automatically). I still have the cert-manager depenency installed for my Helm chart but I’m not sure that I need it if I’m proxying with CloudFlare.

My question

What can cause this? Would CloudFlare mixed with the NGINX upgrade and the cert-manager chart cause too many redirects?

1 Like

I’m also experiencing this exact issue… 4.6.3 is fine, but after an upgrade to 4.7.0, I get “too many redirects” from GitLab in the browser.

In my case, I have haproxy (outside of k8s) in front of GitLab (which is running on k8s), retrieving LetsEncrypt certs. haproxy just sends traffic to the ports for a LoadBalancer which has an IP provided by MetalLB.

I got word back from support that this link might help. I have not yet tried this, though.

1 Like

@zdelfw Thanks for the update. I tried the recommendation at that URL and it seemed to fix the issue in my case! Thanks again!

1 Like

Just in case other people are wondering, I tried the solution in the link and it worked for my configuration as well.