How long for storage quota to update?

How long does it take for storage quota usage to update?

I have an organisation that went over quota, but I deleted some old repos last week. Now the Settings>Usage Quotas>Storage page reports 8.5 GiB of “Total namespace storage used” and as I understand it the Quota is 10 GiB, but when I try to push I still get the error

batch response: Your push has been rejected, because this repository has exceeded its size limit of 10 GB by 1.1 GB. Please contact your GitLab administrator for more information.

Do I just need to wait even longer, or is there a bug here?

Garbage collection needs to be ran but it could take 30 days unless you force running the garbage collection. The commands for it are in the gitlab documentation.

Thanks for the reply @iwalker.

Sorry, I should have specified in the initial post: my group (that I called an ‘organisation’ in the initial post) is on gitlab.com.

I see documentation for how to clean up git-lfs objects on self-hosted Gitlab:

… and I can see how to run ‘housekeeping’ on an individual repo to run garbage collection on an individual repo (Settings>General>Advanced>Housekeepking>Run housekeeping), which from here Housekeeping | GitLab sounds like it would run the garbage collection you mention.

Neither of these help, because the git-lfs cleanup doesn’t (as far as I can see) work for gitlab.com, and I’ve deleted repos to make more space, so I can’t run housekeeping on those repos.

I failed to find any documentation for how to run houskeeping/garbage-collection on a group, so that it would clean up the deleted repos. If anyone has a link (or an alternative suggestion!), that would be awesome!

Is this issue a bug?

I have now waited more than 30 days, but still get the same error when I try to push a commit with an LFS object. I’m guessing that cleanup of the group’s LFS storage may be somehow missing files that belong to deleted repos. Or maybe the accounting is wrong somehow when repos are deleted? The group’s “Settings>Usage Quotas>Storage” page reports 8.5 GiB of “Total namespace storage used” (and has done since I opened this thread on December 16th, more than 30 days ago), I still cannot push an LFS object.

I now think my original problem was just my mistake. I was able to push LFS objects to a different repo in the group. I think the LFS objects I was trying to push were bigger than I realised, and would have caused the repo I was trying to push to to go over the 10 GiB quota.