HTTP 502 Waiting for GitLab to boot

Hello! I am using gitlab-ee on Debian. I first noticed this when using 16.10.4, however the problem persisted after upgrading to 16.11.1. It used to work fine until last week, currently I am getting the following message when trying to access the web UI:

Noticed the following when trying to run sudo gitlab-ctl tail:

==> /var/log/gitlab/gitlab-workhorse/current <==
{"correlation_id":"01HWJXY258FWGCBPD2BWC0HHFJ","duration_ms":0,"error":"badgateway: failed to receive response: dial unix /var/opt/gitlab/gitlab-rails/sockets/gitlab.socket: connect: connection refused","level":"error","method":"GET","msg":"","time":"2024-04-28T19:02:04+01:00","uri":"/"}

Tried sudo gitlab-ctl reconfigure, that did not help. Do you guys know anything that can help getting it back up and running? Thank you!

Hi, any luck fixing this? I am trying to install GitLab in a Proxmox LXC container. I used a proxmox helper script to create a container with docker, and am unable to get past the screen you showed in your post at http://xxx.xxx.x.xx:80

edit: placeholder for ip address wasn’t showing up right

Exactly the same error here.

Also found ruby using a lot of cpu:

    PID USER      PR  NI    VIRT    RES    SHR S  %CPU  %MEM     TIME+ COMMAND
 644291 git       20   0  384332 273084  22016 R  98.0   0.2   0:08.85 ruby

Any idea anyone?