I can' connect to my server remotely in personal

This one’s really weird. After not being able to connect remotely, I figured out I need to add a couple of port forwards (22 and 9418) to get things working remotely. It seems, however, that after doing that, I can’t access the server locally! This is driving me crazy, it makes no sense.

I get this error when trying to push/pull locally:

fatal: unable to access 'http://git.ghostlyco.de/revxx14/new-site.git/': Failed connect to git.ghostlyco.de:80; No error

But everything’s still working fine remotely (tested using my phone’s internet tethering).

I’ve tried using the server’s IP address, it’s local IP address, and I’ve tried it on two machines, one of which I just wiped out and installed everything from scratch.

Has anyone heard of this before? Is there something I can do to correct it?

Alright, apparently the local IP is working now. No idea why, but it is. I guess that’s fine for now, but does anyone know why accessing it from the external IP or domain name could cause issues?