I need to upgrade Gitlab with SSL from version 13.6.5 to 13.7.9/13.9.0/13.9.4. Suggest the steps

Hi Team,
I need some help to upgrade my Gitlab-ce from 13.6.5 to 13.7.9/13.9.0/13.9.4 any versions mentioned. Below are the gitlab version details:

Thanking in advance.
Gireesh Shivapurmath


As per the Gitlab docs: upgrade path Upgrading GitLab | GitLab

you can go straight from 13.6.5 to latest 13.12.x. The remainder in terms of how to do it can also be found in the Gitlab upgrade docs here: Upgrading GitLab | GitLab

1 Like

Thank you so much. I will try that and let you know if there are any errors.

What is the latest stable gitlab-ee version for 13.12.x to upgrade. We tried 13.12.4 it is failed.

13.12.5 from memory

Thank you. I’ll check with this upgrade now.

Generally what is the reason for nginx showing “access denied” or “nginx file does not exist” errors after gitlab-ee upgrade.

We are running gitlab-ee on Cent OS 7.0.

Sorrym OS is RHEL 7.9 Maipo

Team, I’m getting the below errors when I tried upgrading to 13.12.5 and 13.12.0.

chpst: fatal: unable to run: /opt/gitlab/embedded/sbin/nginx: access denied
chpst: fatal: unable to run: /opt/gitlab/embedded/sbin/nginx: file does not exist.

Please suggest some help.

Gireesh Shivapurmath