Is this a bug? Gitlab-Runner does not work on Windows/Docker but it works on Linux

Hello all,

I use (NO self-hosted) and I get this error when I run my CI using a Gitab-Runner installed on Windows or within Docker, precisely just after I do docker build, it works ok if I use a Gitlab Runner installed on Linux or I use shared runners:

Get x509: certificate signed by unknown authority

I have tried to enable/disable TLS but then I get the following error:

no active session for deyvlborrpy89ibo2fvk9xxb9: context deadline exceeded

I have read this might be related to certificates as well but I do not know why this is happening even with TLS is disabled with:


My Docker runner configuration is:

  name = "Windows Docker Kindoi Runner"
  url = ""
  token = "SRtsrp5NYxiAKRxKxYk4"
  executor = "docker"
    tls_verify = true
    image = "docker:19.03.12"
    privileged = true
    disable_entrypoint_overwrite = false
    oom_kill_disable = false
    disable_cache = false
    volumes = ["/cache", "/certs/client"]
    shm_size = 0

And within my ci yml file:

    - docker
  stage: test
  image: docker/compose:1.27.4
    - docker:19.03.12-dind
    - echo "$CI_REGISTRY_PASSWORD" | docker login -u $CI_REGISTRY_USER --password-stdin $GITLAB_REGISTRY

Anyone knows how to fix this certificate issue? I have tried adding stuff like:

  DOCKER_DRIVER: overlay2
  DOCKER_CERT_PATH: "/certs/client"
  DOCKER_HOST: "tcp://docker:2376"

Any help or hint would be really appreciated. I have been trying to solve this for several days without any success. Thank you in advance and regards.