Issue with GitLab Pages default URL

Hello, I hope this message finds you well. (This is my first time asking for help on a forum).

I have a personal GitLab Pages website and I’m currently facing a problem. The following link works as expected: https://vfagnon.gitlab.io/vfagnon.gitlab.io/ , but the root link https://vfagnon.gitlab.io/ no longer works. It worked until this week and I haven’t made any changes. I haven’t seen any changes in any changelog or anything.

The project is publicly available at: https://gitlab.com/vfagnon/vfagnon.gitlab.io

I want to be precise - I have absolutely no experience of DevOps, or familiarity with the terminology. It may be a simple three-click fix, but I still don’t get it. Thank you for taking the time to read this message. See you soon!

I too am facing a similar issue. In my case, I have a group named DesQ, and I have a project desq.gitlab.io under this group. I have been using this for quite a while now (2-3 years atleast), and all of a sudden, https://desq.gitlab.io has stopped working. Instead, it shows up at https://desq.gitlab.io/desq.gitlab.io. Any pointers would be quite helpful.

@vfagnon I figured out that this is a recently introduced bug in gitlab. An MR with a fix has already been opened.
Bug report: When Project Path has an Upper Case, lower case pages URL returns 404 (#438699) · Issues · GitLab.org / GitLab · GitLab
MR that caused the problem: Fix pages with case sensitive paths (!142188) · Merge requests · GitLab.org / GitLab · GitLab
MR that fixes the problem: Revert: Fix pages with case sensitive paths (!142638) · Merge requests · GitLab.org / GitLab · GitLab

2 Likes

there was a capital letter in my username => so in the project URL
thank you very much! I’d never have worked that out on my own!

(I’ve changed my username to lower case, and it seems to be working so far; thanks for the links, I’m going to learn a lot from them)

1 Like

@vfagnon FYI: it was a gitlab bug. It’s fixed now. You can use capitals in your user name and project slugs.