Issue with node image

Hey there, I had my CI set up to use a node image and it was working fine up until this morning. Now I am getting this error messaging:
Running with gitlab-runner 10.6.0 (a3543a27) on docker-auto-scale fa6cab46 Using Docker executor with image node:8.11.0 ... Pulling docker image node:8.11.0 ... ERROR: Preparation failed: Error: No such image: node:8.11.0 Will be retried in 3s ... Using Docker executor with image node:8.11.0 ... Pulling docker image node:8.11.0 ... ERROR: Preparation failed: Error: No such image: node:8.11.0 Will be retried in 3s ... Using Docker executor with image node:8.11.0 ... Pulling docker image node:8.11.0 ... ERROR: Preparation failed: Error: No such image: node:8.11.0 Will be retried in 3s ... ERROR: Job failed (system failure): Error: No such image: node:8.11.0
Just wondering what I am doing wrong here. My gitlab-ci.yml looks like this:

`
variables:
S3_BUCKET_NAME: “”

before_script:

  • apt-get -qq update
  • apt-get -qq install -y build-essential

stages:

  • build
  • deploy
  • clean_up

build:
image: node:8.11.0
stage: build
artifacts:
paths:
- build/
script:

  • npm -g install npm --silent
  • npm set progress=false
  • npm install --silent
  • npm run build

deploy_prod:
image: python:latest
stage: deploy
script:

  • pip install awscli
  • aws s3 cp ./build s3://$S3_BUCKET_NAME/ --recursive
    only:
  • master

clean_up_job:
stage: clean_up
script:

  • rm -rf node_modules
  • rm -rf ~/.node-gyp
    when: on_failure
    `

Cheers!

Hello

Well, I use npm without using the image tag.
Does it work manually? Do you have access to run a “docker images”?

Here is a similar report https://gitlab.com/gitlab-org/gitlab-runner/issues/2247

Npm fails without the image tag. It has started working again this morning. I guess I will revisit this if it starts happening again. Thanks for the reply though!