Jenkins Integration "Validations failed"

On v14.4.2, I’m trying to set up a Jenkins integration for my project. However, whenever I click Test Settings on the integration config page, I always get a “Validations failed” popup message. This leaves me without any idea what is actually wrong.

One thing that is not clear from the documenation is what form the ‘Project’ field is meant to take, it talks about copying the URL but that has a lot of “/job” sections (as the target job is in a folder). Are those meant to be included? I’ve tried both with and without those sections without success.

Does it matter that the job I’m trying to invoke is a multibranch pipeline?

Does the URL field need a trailing slash? Again, I’ve tried it both ways.

When I attempt to save the settings, it reloads the form and appears to have succeeded, but when I reenter the config page, the settings have been discarded.

Any ideas on how to investigate this further are appreciated.

1 Like

having the same issue - zero hints on what failed. :confused:

Hi there,

I was facing to the same issue. The reason is that the Jenkins URL points to the same IP address which GitLab is using.

Such webhooks are forbidden by default and can be enabled in the GitLab settings Admin → Settings → Network → Outbound Requests → Allow requests to the local network from hooks and services.

Once I did it, I was able to configure the Jenkins Integration.

1 Like

Thanks for the suggestion. That setting was already enabled on our server.

Fortunately for me, but unfortunately for everyone else I guess, our issue resolved itself.

The one thing that happened at the time was that all our internal IP addresses were changed. I suspect there was some network configuration that was interfering, but that’s as far as I’m able to go.