JIRA Development Panel, no repositories to select

jira

#1

Hi,
We are trying to connect an on-premise JIRA (7.12.3) with and on-premise Gitlab (11.4.5ee) installation using this guide: [https://docs.gitlab.com/ee/integration/jira_development_panel.html ]

Everything seemed to go very well during the configuration process, including the oAuth flow from JIRA to Gitlab. The problem is in the step where you would select a repository to sync. There are no repositories in the list, even after manually refreshing.
Our Gitlab configuration uses a ‘Development’ group where the project is part of. We tried configuring JIRA with group-id/user-id “Development” and we tried it with the username of the admin configuring the connection.
All permissions seem to be setup alright. Gitlab is not running under a relative url.

What could we miss here?


#2

It seems that Jira is calling API v3.

I guess I’m not the only one with this issue, another user in https://gitlab.com/gitlab-org/gitlab-ee/issues/6811 mentions the exact same problem.

If anyone can suggest a workaround, I would be happy to hear.