Kubernetes KAS write PROJECT NOT FOUND

I installed GitLab 16.5 in a separate virtual machine, activated KAS and connected the Kubertetes Agent. The agent successfully communicates with GitLab, but when trying to sync the project it gives a “project not found” error. The project is public and everything was done according to the instructions as indicated here GitLab Kubernetes Agent Setup Walkthrough - Round 2 - YouTube. Distinguish only in self-hosted installation and gitlab version.

1 Like

Having the exact same issue, even tried creating another public project with my manifest config and it’s still the same error. Also on a self-hosted GitLab instance. I tried changing the id with “my-group/repo-name”, “https://git.self-hosted.com/my-group/repo-name” and even using the project id.

Running on GitLab Enterprise Edition 14.9.2-ee

  "level": "error",
  "time": "2022-04-07T17:21:12.032Z",
  "msg": "GetObjectsToSynchronize.Recv failed",
  "mod_name": "gitops",
  "project_id": "usersina/my-nginx-test",
  "agent_id": 7,
  "error": "rpc ││  error: code = NotFound desc = project not found",
  "correlation_id": "01G02GPPSAA2YEWM8EPHS7AQ3P"