LDAP Tab Issue on GitLab UI

Hi I have an issue with LDAP tab on GitLabUI. Configured with the below details, I replaced confidential details by xxxxx:

LDAP settings:

gitlab_rails[‘ldap_enabled’] = true
gitlab_rails[‘ldap_servers’] = YAML.load <<-‘EOS’
main: # ‘main’ is the GitLab ‘provider ID’ of this LDAP server
label: ‘LDAP’
host: ‘xxxxx’
port: 389
uid: ‘xxxxx’
bind_dn: ‘cn=xxx,dc=xxx,dc=xxx’
password: ‘xxxx’
encryption: ‘plain’ # “start_tls” or “simple_tls” or “plain”
verify_certificates: true
active_directory: true
base: ‘cn=xxx,cn=xxx,cn=xxx,dc=xxx,dc=xxx’
group_base: ‘cn=xxx,cn=xxx,dc=xxx,dc=xxx’
admin_group: ‘Global Admins’

And when I run the “sudo gitlab-rake gitlab:ldap:check”
Checking LDAP …

Server: LDAP
LDAP authentication… Success
LDAP users with access to your GitLab server (only showing the first 100 results)
DN: cn=xxxx,cn=xxx,cn=xxx,dc=xxx,dc=xxxx.

So when I tried to open the GitLab, I couldn’t able fo find LDAP tab on the UI.

Many thanks for your help.

Hi lpujari,

I would request you to run the below command after the ldap setting and post the output of the command for better understanding:

  1. to reconfigure the gitlab:(run as root)
    gitlab-ctl reconfigure

  2. to restart the gitlab:(run as root)
    gitlab-ctl restart


Hi Akhilesh,

Here is the output for gitlab-ctl restart:

root@gittutest:/# gitlab-ctl restart
ok: run: gitaly: (pid 17500) 0s
ok: run: gitlab-monitor: (pid 17510) 1s
ok: run: gitlab-workhorse: (pid 17514) 0s
ok: run: logrotate: (pid 17524) 1s
ok: run: nginx: (pid 17530) 0s
ok: run: node-exporter: (pid 17537) 1s
ok: run: postgres-exporter: (pid 17548) 0s
ok: run: postgresql: (pid 17563) 0s
ok: run: prometheus: (pid 17573) 0s
ok: run: redis: (pid 17579) 0s
ok: run: redis-exporter: (pid 17586) 1s
ok: run: sidekiq: (pid 17607) 0s
ok: run: unicorn: (pid 17616) 1s

Hi lpujari,

Thanks for posting output of the above command but i need more elaboration,as i have already seen that your LDAP setting seems good, the LDAP setting you have shared on forum is that same on gitlab.rb file or you have make some change if you have done then please share the latest LDAP setting so i can easily rectify the problem and resolve it.
Some time gitlab start misbehaving so please after the LDAP setting please reboot your machine and run the above command which i have already shared and then open the gitlab gui.
Hope the above step will help you,please feel free to reply on this query.



The same gitlab.rb file I have used. I haven’t made any changes to the file. And done rebooting my machine whenever I made changes in the gitlab.rb file.