Login issues 422 (2FA is Broken)

Update:
I can still use my phone to see the web UI, and able to get to my repo on my phone, trying to disable 2FA also return 422, which means that 2FA is broken.

Hello,
Looks like new machine/browser login with 2FA doesn’t work.

I can login, but when I enter my 2FA Pin its saying 422… How can I fix this?

Even using my recovery code doesn’t work, what happened here?

Melvin

3 Likes

Hi any fixes yet? I’m having the same exact issue, thanks.

I’m getting this same error when trying to log on at gitlab.com with 2FA. I’ve tried syncing my timezone, time correction on Google Authenticator, switching browsers, incognito. Nothing.

1 Like

same for me, also resetting the password does not work: "Website url is not a valid URL" on Login - #3 by esstheevau

I’ve found this : https://www.reddit.com/r/gitlab/comments/ph13yf/after_input_2fa_code_to_login_has_error_422/

This was caused by this MR: Validate user website_url (!69436) · Merge requests · GitLab.org / GitLab · GitLab. Users that have an invalid website URL in their profile are unable to login via 2FA.

The MR is being reverted here: Revert "Validate user website_url" (!69532) · Merge requests · GitLab.org / GitLab · GitLab. Once this MR hits production, the issue will be resolved.

Looks like it was just fixed! I can see things now.

1 Like