Mail to set password is not sent any more after upgrade

Hello,

I am hosting GitLab on a private Ubuntu 14.04 server.
Our policy is to prevent unknown people from signing up. The admin manually creates
account for each of the team members. So far, it worked very well and new team members
would receive an email allowing them to set their passwords.

However, since I upgraded GitLab from version 7 to version 8, the mails are not received anymore,
forcing the admin to manually input a password and ask the new members to change it as soon as they
log in for the first time.

I did not change any settings, so I am clueless about why the mails are not sent (nor received)
any longer. I tried several email providers, rebooted several times and ran countless times sudo gitlab-ctl reconfigure, to no avail. By the way, postfix should be properly configured as GitLab sends other mails without problem.

FYI, the server is now running 8.0.3-ce.1, installed through the Omnibus package.

Thank you very much for your help.

I finally solved the problem when looking at the postfix logs in /var/log/mail.log .
For some reason postfix was forcing the use of IPv6 for addresses for which only an IPv4 is allocated, thus it failed.
I configured postfix to use IPv4 in /etc/postfix/main.cf .