Maven plugin versions ignoring gitlab maven package registry

Hi there! I’m facing the following situation:
I have two java project, which are working correctly to build and deploy my artifact (.jar file) to gitlab package registry.
Project B has a dependency on jar file generated from project A.
There’s no issue with common mvn package, install and deploy commands.
But I want to use the maven versions plugin to automatically update the pom.xml file if the project A jar file changes his version (eg. from 1.0.0 to 1.0.1).
When I run the following command:
mvn versions:display-dependency-updates -Dverbose=true -s ./ci_settings.xml
The process tells me that maven checks for updates on my gitlab (SaaS) but it founds none, and declares that 1.0.0 version is the latest available, but looking through the web UI, I can clearly see both versions available: 1.0.0 and 1.0.1

Anybody has faced the same situation? Does anybody know another solution to automatically update the version of specific artifacts?

Thanks in advance!!

Yes. Same problem!
Do you find any solution?

Hi! Unfortunately I didn’t find a simple solution for that.
I used a combination of mvn package -U -Dinclude=xxxx and maven version range syntax, but that doesn’t update your pom.xml file.

We also have the same issue.
@marcosp would you mind creating an issue for that?

Ha, never mind. For me upgrading the versions plugin to version 2.15.0 (from 2.12.0) solved the issue.