Middle Click opens sidebar

Version: GitLab Enterprise Edition 14.2.3-ee

This is more of a bug report than a question, but I’ve noticed that the sidebar now opens when middle clicking an issue’s title in order to bring up the issue detail page in another tab. This didn’t used to happen I think. Is this intended behavior or a bug?

I’m using Firefox, and middle-clicking opens a new tab. So I don’t think it’s anything to do with Gitlab, but the particular browser you are using and it’s configuration deciding what a middle-click does. I am also using 14.2.3.

It does open a new tab, but it also opens the sidebar which it didn’t used to do. Usually left clicking on the main area of the issue would select/open and deselect/close the sidebar.

I’ve tried Firefox/Chrome/Brave, and all work as intended. It opens in a new tab without the sidebar. I think you should check your browser configuration.

If you click links on other sites with the middle button, does it also open the sidebar?

Would also help if you post, what operating system: Windows/Linux/Mac and also what browser you are using and version. Also, disable plugins, or use in private/incognito mode when all plugins are disabled and see if the problem follows. Also try different browsers, which can also mean ruling out problems with your browser settings causing the problem.

Interesting, I’ve taken a screen capture of what I’m seeing. I also just tried this on another GitLab account with version:

GitLab Enterprise Edition 14.3.0-pre cca1122a84b

and was not able to replicate the issue. Apparently this was fixed in the latest version that’s hosted on Gitlab.com.

Here is a neofetch of my OS:

                   -`                    mliu@servalWS
                  .o+`                   -------------
                 `ooo/                   OS: Arch Linux x86_64
                `+oooo:                  Host: Serval WS serw11-b
               `+oooooo:                 Kernel: 5.13.13-arch1-1
               -+oooooo+:                Uptime: 2 days, 23 hours, 37 mins
             `/:-:++oooo+:               Packages: 1058 (pacman)
            `/++++/+++++++:              Shell: fish 3.3.1
           `/++++++++++++++:             Resolution: 3840x2160, 1920x1080, 3840x2160
          `/+++ooooooooooooo/`           WM: i3
         ./ooosssso++osssssso+`          Theme: Nordic-darker [GTK2/3]
        .oossssso-````/ossssss+`         Icons: Flat-Remix-Grey-Dark [GTK2/3]
       -osssssso.      :ssssssso.        Terminal: tmux
      :osssssss/        osssso+++.       CPU: Intel i9-9900K (16) @ 5.000GHz
     /ossssssss/        +ssssooo/-       GPU: NVIDIA GeForce RTX 2060 Mobile
   `/ossssso+/:-        -:/+osssso+-     Memory: 11331MiB / 15815MiB
  `+sso+:-`                 `.-/+oso:
 `++:.                           `-/+/
 .`                                 `/

and a gif of what I see. Note that this is a middle click on the title:


Ah I get you now. You are under the boards section of issues. Yes, under boards on mine if I click an issue middle click then I also get that side bar on the right. If you were under Issues → List or Issues → Milestones then it works normally.

It wasn’t clear in your previous posts of where exactly in Gitlab you were clicking. I was doing it under Issues List and couldn’t replicate it. Only now I could replicate it when I saw your GIF, although it was rather small to read the text in it, but it was enough to figure out where you were.

I guess we wait until 14.3.0 is released since if it’s resolved in that as you say, then there won’t be much point opening an issue for it to report the issue.