Migration from CE to EE

I have done migration form CE to EE followed by the link https://docs.gitlab.com/omnibus/update/README.html#from-community-edition-to-enterprise-edition.

Then i got this error Whoops, GitLab is taking too much time to respond.. Please help me to solve this.

CE Version : 11.10.4-ce.0
EE Version : 11.10.4-ee.0
OS - Ubuntu 16.04.

What is your output from “gitlab-ctl status”?

That might point you in the right direction or otherwise use “gitlab-ctl tail” to show you the logs.
If that doesn’t help, you might be able to get support, as you seem to have a paid version.

Hi bartj,
Thanks for your reply, I am getting the below error.

`2019-05-24_14:18:29.22003 failed to start a new unicorn master
2019-05-24_14:18:29.23245 starting new unicorn master

==> /var/log/gitlab/unicorn/unicorn_stderr.log <==
I, [2019-05-24T19:48:29.687970 #1665] INFO – : Refreshing Gem list

==> /var/log/gitlab/gitlab-rails/sidekiq.log <==
2019-05-24_14:18:33.24896 PG::UndefinedTable: ERROR: relation “geo_nodes” does not exist
2019-05-24_14:18:33.24898 LINE 8: WHERE a.attrelid = ‘“geo_nodes”’::regclass
2019-05-24_14:18:33.24898 ^
2019-05-24_14:18:33.24898 : SELECT a.attname, format_type(a.atttypid, a.atttypmod),
2019-05-24_14:18:33.24898 pg_get_expr(d.adbin, d.adrelid), a.attnotnull, a.atttypid, a.atttypmod,
2019-05-24_14:18:33.24898 (SELECT c.collname FROM pg_collation c, pg_type t
2019-05-24_14:18:33.24899 WHERE c.oid = a.attcollation AND t.oid = a.atttypid AND a.attcollation <> t.typcollation),
2019-05-24_14:18:33.24899 col_description(a.attrelid, a.attnum) AS comment
2019-05-24_14:18:33.24899 FROM pg_attribute a LEFT JOIN pg_attrdef d
2019-05-24_14:18:33.24899 ON a.attrelid = d.adrelid AND a.attnum = d.adnum
2019-05-24_14:18:33.24900 WHERE a.attrelid = ‘“geo_nodes”’::regclass
2019-05-24_14:18:33.24900 AND a.attnum > 0 AND NOT a.attisdropped
2019-05-24_14:18:33.24900 ORDER BY a.attnum
2019-05-24_14:18:33.24900 /opt/gitlab/embedded/lib/ruby/gems/2.5.0/gems/activerecord-5.0.7.2/lib/active_record/connection_adapters/postgresql/database_statements.rb:88:in async_exec' 2019-05-24_14:18:33.24900 /opt/gitlab/embedded/lib/ruby/gems/2.5.0/gems/activerecord-5.0.7.2/lib/active_record/connection_adapters/postgresql/database_statements.rb:88:inblock in query’
2019-05-24_14:18:33.24901 /opt/gitlab/embedded/lib/ruby/gems/2.5.0/gems/activerecord-5.0.7.2/lib/active_record/connection_adapters/abstract_adapter.rb:590:in block in log'

Sorry, this is to deep inside gitlab for me (and I completely missed your reply, sorry for that) I’d advice to refer to Gitlab, as you seem to have support not.

This probably indicates that the database schema was not upgraded properly. One way to do this is to import a community edition backup into an enterprise instance, but I’m sure there are others.

Look at your db migration status:

# gitlab-rake db:migrate:status RAILS_ENV=production

You’ll probably find that some of those are down. So fire them up:

# gitlab-rake db:migrate RAILS_ENV=production

Then do the usual to get things going again:

# gitlab-ctl reconfigure
# gitlab-ctl restart
# gitlab-rake gitlab:check SANITIZE=true

Figured this out by going here:
https://docs.gitlab.com/ee/development/database_debugging.html