Migration from standalone gitlab to standalone gitlab does not display activity in order

We had a 7.4.0 source install which I upgraded to a 7.4.0 omnibus installation. I then upgraded it up to 8.17.0, to match the other standalone server we were migrating to.

I exported one repository and imported it into the new gitlab instance.

What I’ve noticed:

  1. The Activity list is completely in reverse order, with no way to correct it. I’m seeing Merge Request 1 from 2 years ago at the top of the list, instead of the most recent one from a few days ago.

  2. Push events are not transferred.

Would really like for #2 to be there, but #1 is the real sticking point.

I’ve attempted this in 8.17.0 and I also attempted to upgrade the original server to 9.0.0 and do an export and reimport into itself, with the same results. No push events and the activity list in reverse order. This is reproducable, as I’ve tried repeatedly to export/import on the 2 different versions.

Hi

Please try this command for reversed activity.
sudo gitlab-rake cache:clear --trace
restart gitlab and check.

Cache clear will re load the info in the UI.

Just tried that and it did not appear to do anything.

I have gotten the merge requests to display properly. What I had to do was:

Load the project.json file into rails, reverse the merge_requests array and save the JSON back out. Replace that file in the tar.gz file and import.

This doesn’t take long but is a pain to do for each and every repository we want to move.

The push events still don’t migrate over, so I still have a problem. If there is an easier way to do the above, that would be helpful, too.