Mirrored public github repository's pull requests don't trigger CI

Hi!

We have a repo mirrored from github at https://gitlab.com/JuliaGPU/MakieGallery-jl and we use Gitlab for CI. The basic functionality works great. What I haven’t been able to setup is that pull requests on github also trigger CI. The branches themselves do trigger CI, but not the pull requests. This matters because I need to infer from the CI environment variables that I’m dealing with a pull request and run a differently configured pipeline for that case. Basically, the variable CI_EXTERNAL_PULL_REQUEST_IID is never set to anything.

I have read somewhere that I need to specifically enable external pull requests in the gitlab yaml file.
I do have these lines in the yaml file, under the relevant job:

only:
    - master # trigger docs on master branch changes
    - external_pull_requests # trigger docs on PRs (only internal, not from forks)

But pull requests don’t trigger anything that I can see. I tried a rules workflow as well at some point, but that didn’t help. Do you have any ideas what I can check? I read a lot of documentation but it didn’t clarify the issue for me.

Thank you for your help!
Julius

I fixed it, the webhook settings in github for some reason didn’t have pull requests included as triggers, only push events.