New instance, set password, always 422 error page

Just installed a new instance of Gitlab on a Debian9 system via: https://about.gitlab.com/installation/#debian

Access my server url:

Enter a password and get:

Tried multiple passwords, always the same thing. Can’t get past this, and none of the additional configuration information addresses where to even being to debug something like this.

Any ideas?

Hello hello hello?

Is anybody there?

For additional information.

I completely built a ubunut16LTS server machine, and following the instructions for installation for that OS

My gitlab server is named: ubuntugitlab.lan.zacwolf.com

sudo EXTERNAL_URL="http://ubuntugitlab.lan.zacwolf.com" apt-get install gitlab-ee

SAME EXACTLY BEHAVIOR!!!

Additional information about how I have this configured.

I have ubuntu running on a MS Hyper-V Virtual Machine: It’s using a Bridged network config, so the server gets is own IP address from the same DHCP server as ever other machine on my network. Since this is a private network, firewalled from the Internet, I have my own private domain: lan.zacwolf.com and a dhcp server that provides IP addresses via DHCP AND adds private DNS entries for the IP addresses that it gives out.

From any machine on my network I can ping: ubuntugitlab.lan.zacwolf.com which will resolve to the correct IP address which will respond to the pings.

From the ubuntu server itself I can even ping ubuntugitlab.lan.zacwolf.com and it resolves to the local IP address, so unless I missing something important, this shouldn’t have anything to do with my network settings, right?

Just to make sure this wasn’t some weird reverse DNS issue, FROM the gitlab server box I ran the following:

zac@ubuntugitlab:~$ nslookup 192.168.1.2
2.1.168.192.in-addr.arpa        name = home-asus.lan.zacwolf.com.

Authoritative answers can be found from:

zac@ubuntugitlab:~$ dig -x 192.168.1.2

; <<>> DiG 9.11.3-1ubuntu1.1-Ubuntu <<>> -x 192.168.1.2
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 12361
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 65494
;; QUESTION SECTION:
;2.1.168.192.in-addr.arpa.      IN      PTR

;; ANSWER SECTION:
2.1.168.192.in-addr.arpa. 0     IN      PTR     home-asus.lan.zacwolf.com.

;; Query time: 6 msec
;; SERVER: 127.0.0.53#53(127.0.0.53)
;; WHEN: Thu Aug 02 17:45:38 UTC 2018
;; MSG SIZE  rcvd: 92

zac@ubuntugitlab:~$ ping home-asus.lan.zacwolf.com
PING home-asus.lan.zacwolf.com (192.168.1.2) 56(84) bytes of data.
64 bytes from home-asus.lan.zacwolf.com (192.168.1.2): icmp_seq=1 ttl=128 time=0.240 ms
64 bytes from home-asus.lan.zacwolf.com (192.168.1.2): icmp_seq=2 ttl=128 time=0.188 ms
64 bytes from home-asus.lan.zacwolf.com (192.168.1.2): icmp_seq=3 ttl=128 time=0.185 ms
64 bytes from home-asus.lan.zacwolf.com (192.168.1.2): icmp_seq=4 ttl=128 time=0.198 ms
64 bytes from home-asus.lan.zacwolf.com (192.168.1.2): icmp_seq=5 ttl=128 time=0.167 ms
^C
--- home-asus.lan.zacwolf.com ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4059ms
rtt min/avg/max/mdev = 0.167/0.195/0.240/0.028 ms

home-asus.lan.zacwolf.com is the machine that I am making the chrome request to http://ubuntugitlab.lan.zacwolf.com from. So according to all of the above, the gitlab server, and do a full reverse DNS lookup of the machine that the browser is coming from.

JUST TO CLARIFY! The first access to the website is not meant to come from the same IP address as the gitlab server is it? I don’t install desktops on my linux machines, so I don’t even HAVE a browser configured on the server, so if this IS expected behavior is there some way to use a config tool to set the initial root/admin password, so that I can then access the server from another machine on the network?

I had the same issue and it stemmed from me having generated an TLS certificate with Let’s Encrypt before I installed gitlab. After reading this forum and others, I realized that the external_url configuration option in /etc/gitlab/gitlab.rb had to be set to http instead of https. When I ran gitlab-ctl reconfigure after changing that, the password and everything worked as planned. I wrote up a tutorial here that might be of help.