Nginx 0.6.x < 1.20.1 1-Byte Memory Overwrite RCE


we scanned our Gitlab community instance with Nessus vulnerability scanner and it detected the following vulnerability:

[High] nginx 0.6.x < 1.20.1 1-Byte Memory Overwrite RCE


According to its Sever response header, the installed version of nginx is 0.6.18 prior to 1.20.1. It is, therefore, affected by a remote code execution vulnerability. A security issue in nginx resolver was identified, which might allow an unautheticated remote attacker to cause 1-byte memory overwrite by using a specially crafted DNS response, resulting in worker process crash or, potentially, in arbitrary code execution.

Note that Nessus has not tested for this issue but has instead relied only on the application’s self-reported version number.

Path : /opt/gitlab/embedded/sbin/nginx
Installed version : 1.18.0
Fixed version : 1.20.1 / 1.21.0

What can we do to fix this or can we expect an update to this?

Please see the open issue on this:

1 Like

Thank you for this information.