No Login Page when upgrading

Hello,
I just upgraded from Gitlab EE 11.8.0 to 11.11.4.
I was upgrading to fix an ACMEv1 error for letsencrypt.

I ran $sudo apt update && sudo apt upgrade, which updated Gitlab to 12.5.3
Upgrades ran without any errors.

I then ran $sudo gitlab-ctl reconfigure, again everything went fine.
But now I’m still getting the page that says, " Please log into your Droplet with SSH to configure the Gitlab installation."

How can I get the login page to load? I’m also hoping my git repositories are still on the server…?
Any help/suggestions would be greatly appreciated.

Let me know if I need to post more information? I’ve followed the standard procedures to update and setup. Except this isn’t a setup, just an upgrade to fix the error I was encountering. Everything was running fine before.

Here’s an image of what I get when I go to my ip address/url.

So turning off letsencrypt seemed to fix the issue and gave me the login page. Seems like something is wrong is with that service.

Editing the file /etc/gitlab/gitlab.rb and setting the following:

letsencrypt['enable'] = false

I then ran $sudo gitlab-ctl reconfigure and the sites login page was back up. I was hoping to have an automatic renewal of the SSL cert, but it looks like I’ll be just updating it manually via certbot.

Seems you’re affected too: Lets Encrypt Error

2 Likes

Indeed. I wouldn’t say my solution is a fix for the issue, but at least will get people back up and running at least until letsencrypt is up and running again.
I’ve also learned a great deal about updating and backing up my Gitlab. Kind of glad I ran into this issue.

Yep, every workaround is needed to keep production running, I truly understand that :slight_smile:

I’ve commented on the issue with getting a nice feedback:

https://gitlab.com/gitlab-org/omnibus-gitlab/issues/4900#note_257737158

This is being included, and backported, into the next releases of 12.2.x through 12.5.x

1 Like