Not able to access from office network

Been running GitLab CE on Google Cloud Compute Engine for a while without any issue. Did merging and cloning of projects today without issue. Suddenly, later in the day, I was not able to access GitLab from our office. Could not ping and trace route “Request timed out”

However, the instance was accessible from the outside the office without any problem. I tried restarting the VM instance and GItLab was accessible for about 5 mins then unreachable.

I’ve also tried assigning a different external IP to the VM but still not reachable from office but reachable elsewhere.

Any help is much appreciated.

GitLab CE 8.17.2 Omnibus


Hmmm, it started working again this morning. Might just be ISP routing problem??? Weird.

Alright. Found out why the server was not accessible.

“sshguard” picked up our office IP as suspicious and blocked access. Once I add our IP to whitelist, access was restored.

In case anyone else run into the same problem with Google Cloud Ubuntu 16.04 instance.

Didn’t know it was installed by default.