Not recieving Gitlab CE Confirmation email

GitLab Community Edition is setup as a subdomain to an Apache reserve proxy. During the set-up/configuration process the “Change your password” was reached. However, the confirmation email was never received. Attempts to “Request a new one” are not received even though the pretty message says an email has been sent.

Is there a setting in gitlab-ctl.rb to overcome this?

Also, a previous attempt to install GitLab CE was deleted. During the previous attempt an email was received and moving passed “Changed your password” was achieved. The previous attempt was deleted after the step of switching the root user name.

Is it possible that a sys admin person would locate the deleted / dormat / abandoned account and reset/delete the paramater or account so the confirmation email will be sent?


OK, I am in. I had made note of the previous passwords used on the previous “deleted” GitLab CE and they worked.

Passwords from a previously deleted GitLab was used to enter into a newly configured GitLab.

Regarding the email problem, have you set up email notification as described in

Thanks @alexk !

The issue has been resolved. A previous attempt to install CE was removed. The current CE was asking for a new password and confirmation. I finally gave my previous credentials and was able to get into the current CE. Thank you sir. I’ll mark this solved.