Omnibus CE update to 8.9 failed with PostgreSQL error

ON RHEL 6.6 I am trying to go from a 7.8 CE source install to a 8.9 CE omnibus install. In-Place. I have successfully got to the 7.14.3 omnibus install. This included moving from MySQL to PostgreSQL.

When I ran yum upgrade gitlab-ce most things worked until en error with the db:migrate.

The relevant error, which occurred multiple times during the upgrade was:

Expected process to exit with [0], but received ‘1’
---- Begin output of “bash” “/tmp/chef-script20160701-2024-13tyytz” ----
STDOUT: rake aborted!
StandardError: An error has occurred, this and all later migrations canceled:

PG::UndefinedFunction: ERROR:  function concat(unknown, text, unknown, text, unknown, text, unknown) does not exist
LINE 1:, 't', 'f', 'f', 'f', 'f', 'f', 't', CONCAT('{"...

This appears to be saying that there is no concat function in postgreSQL. I am using 8.4.20

I there a fix or workaround for this I can implement? Is it a bug in the db migrate script?

Stuck at this point.

Many thanks


To answer my own post. I solved the issue. the concat() function was introduced in postgresql in version 9. RHEL 6 installs 8 by default which is what I did.

I added postgresql 9.2 from the postgres repo and migrated the data. After that the gitlab db:migrate ran without causing that error.