Omnibus gitlab and container registry on different servers

Hi,
I would like to ask if someone have any experience in installing gitlab(omnibus) and container registry on different servers. I mean we have two virtuals, on the first one we have omnibus gitlab and on the second we’d like to have a docker container registry installed. I tried to configure it with documentation, especially GitLab Container Registry administration | GitLab, but without any success. Gitlab will start, I can open container registry in my project and see the information about login and pull/push, but when I try the command: docker login [registry-server] with my gitlab credentials I got: Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Post http://%2Fvar%2Frun%2Fdocker.sock/v1.24/auth: dial unix /var/run/docker.sock: connect: permission denied. I tried to troubleshoot the problem, since it seems like the permissions aren’t correct, but again without any success. So I would really like to ask, if anyone of you have done something like this, or if it is even possible to have these two things separately(maybe I would have to install omnibus gitlab on registry server too?). I would be grateful for any help… Thanks!

That’s a problem with docker permissions.

Try

sudo docker login <other> <stuff> 

Alternatively you can add yourself to the docker group in /etc/group restart docker, and log out/back in to the VM to establish the new group credentials. Then the ‘docker’ commands will work without sudo.

Or you can do it with commands:

# Add user to Docker group
sudo usermod -aG docker <username>

# Restart docker 
sudo systemctl restart docker