not available

when i want to update my self hosted instance of gitlab using
sudo apt update (running ubuntu server 18.04)

i got an error failed to fetch signature can’t be verified because no public key available.

Use the install script from packages.You cannot download because the GPG key was not imported.Use the script and instructions from to add the GPG key and continue.
(I had the same problem before)

If you still don’t know,check my video tutorial


1 Like

Thanks that did it :slight_smile:

1 Like

Awesome @sysdl132! Thanks for sharing :sparkles:

Apparently i still have problems, my curernt version is gitlab 12.9.2 whilst the latest is version 13. when I update i got error that i cannot update to the next majore version.
I guess because i’m missing some intermediate version aswell.

Whats the best way to update to the next majore version?

Can you give me the output when you had an error?
Tip:you can try to download the package manully at: ce and ee and run dpkg to install new version
you can also search the forum to find help

1 Like

this is whats happening, after your videos that worked perfectly, but now it still says i got an update so i do :
sudo apt update
sudo apt upgrade

yeah thx for the link i had seen it in the error, however i’m stuck on the recommendations as i see that major version 13 has a new postgrsql version and other stuff to do which seems complex for a simple upgrade


for example the only upgrade comment is this one :slight_smile:
sudo apt-get upgrade gitlab-ee=12.0.12-ee.0

i tried this with other version to upgrade and always got version not found

try to use apt install instead of apt upgrade?

(or you can search google for the APT manual)


Thank u very much install did everything upgraded from 12.9.2->12.9.5->12.10.6->13.1.4

1 Like