Parent pom with maven repository

I have a parent pom that is shared across many projects. I have a ci build that is packaging the pom and sending it to my projects local maven repository. However when I try to reference it I’m getting a build error that its not found. I don’t know if its a file type problem (since its packaging it into pom whereas the dependency is presumably looking for an xml) or if its a group/name/id problem, or whether there is a completely different way I should be referencing it.

This is the error message:
Downloading from base-pom: https://gitlab.com/api/v4/projects/10325360/packages/maven/localgroup:base/base-pom-1.0.pom/1.0/base-pom-1.0.pom-1.0.pom
Downloading from resources: https://gitlab.com/api/v4/projects/PROJECT_ID/packages/maven/localgroup:base/base-pom-1.0.pom/1.0/base-pom-1.0.pom-1.0.pom
Downloading from central: https://repo.maven.apache.org/maven2/localgroup:base/base-pom-1.0.pom/1.0/base-pom-1.0.pom-1.0.pom
3141 [ERROR] [ERROR] Some problems were encountered while processing the POMs:
[FATAL] Non-resolvable parent POM for path:resources:1.0: Could not find artifact localgroup:base-pom-1.0.pom:pom:1.0 in base-pom (https://gitlab.com/api/v4/projects/10325360/packages/maven) and ‘parent.relativePath’ points at wrong local POM @ line 12, column 13

This is my package information:
Package information

  • Name localgroup
  • Version
  • Created on Jan 11, 2019 9:23pm

Maven Metadata

  • Group ID local group
  • Artifact ID base-pom
  • Version
Name Size Created
[maven-metadata.xml] 301 Bytes 1 hour ago

How did you configure your lookup repositories, e.g. repositories resp. pluginrepositories? You are propably better off asking this in the maven User list.

Thanks, I will take a look at Maven directly. I configured it all according to the gitlab maven repository doc It looks like that is working ok since its downloading the package, its just not finding the package.