Persistent "Internal Server Error status=500" on a few jobs in pipeline of one Merge Request

I am using and on certain jobs for pipelines of one Merge Request I am getting persistent “Internal Server Error” at the stage where the job tries to upload data.

Example test from failed job:

WARNING: Uploading artifacts to coordinator... failed id=563420317 responseStatus=500 Internal Server Error status=500 Internal Server Error token=LBQHnkQK735 WARNING: Retrying... context=artifacts-uploader error=invalid argument

I have tried restarting the jobs - same behavior.

I have deleted the pipeline and set it up as a new pipeline from the branch, but the error recurs.

These errors are not happening with other merge request using the same gitlab-ci.yml in the project, leading me to believe the problem is outside of our configuration. It seems to be the same jobs in same stage that get afflicted by it.

I have consulted the GitLab docs about CI pipeline management, but am out of ideas on how to remedy the situation.

Pipeline with failed jobs:

Example of such a job failure:

Hope someone can give me advice.
Thanks in advance.

Tried another thing - clearing my runner caches.

Didn’t solve it either…

Set up another Merge Request based on same change, to see if the pipeline problem would disappear.

Strangely, it did not.

This is the new MR which also fails with the same pattern:

Could it be that the artifacts it tries to upload break something in the uploader or backend that’s receiving the data?

Looks like the pipeline cannot handle filenames with Unicode characters in them.

The MR in question creates a file with U+20BF and U+1F3C3 in it.

None of our other pipelines have this problem.
I will make a few more experiments with the filename, but everything suggests that Unicode support in the filenames is the issue.